2.4. درس: الترميز

ترميز الطبقة هو مظهرها المرئي على الخريطة. وتكمن القوة الأساسية لنظم المعلومات الجغرافية (GIS) مقارنةً بالطرق الأخرى لتمثيل البيانات ذات الجوانب المكانية في أنها توفر لك تمثيلًا مرئيًا ديناميكيًا للبيانات التي تعمل عليها.

لذلك، فإن المظهر المرئي للخريطة (الذي يعتمد على ترميز كل طبقة على حدة) مهم جدًا. يجب أن يتمكن المستخدم النهائي للخرائط التي تنتجها من رؤية ما تمثله الخريطة بسهولة. وبالقدر نفسه من الأهمية، يجب أن تتمكن من استكشاف البيانات أثناء عملك عليها، والترميز الجيد يساعد كثيرًا في ذلك.

بعبارة أخرى، ليس الترميز المناسب ترفًا أو مجرد إضافة لطيفة. بل هو في الواقع ضروري لكي تستخدم نظم المعلومات الجغرافية بشكل صحيح وتنتج خرائط ومعلومات يستطيع الناس استخدامها.

هدف هذا الدرس: أن تتمكن من إنشاء أي ترميز تريده لأي طبقة متجهية.

2.4.1. ★☆☆ تابع معنا: تغيير الألوان

لتغيير ترميز طبقة، افتح Layer Properties الخاصة بها. لنبدأ بتغيير لون الطبقة landuse.

  1. انقر بزر الفأرة الأيمن على الطبقة landuse في قائمة الطبقات.

  2. اختر عنصر القائمة Properties... من القائمة التي تظهر.

    ملاحظة

    افتراضيًا، يمكنك أيضًا الوصول إلى خصائص الطبقة بالنقر المزدوج على الطبقة في قائمة الطبقات.

    نصيحة

    يفتح الزر symbology الموجود أعلى اللوحة Layers اللوحة Layer Styling. يمكنك استخدام هذه اللوحة لتغيير بعض خصائص الطبقة: افتراضيًا، ستُطبَّق التغييرات فورًا!

  3. في النافذة Layer Properties، اختر التبويب symbology Symbology:

    ../../../_images/layer_properties_style.png
  4. انقر على زر اختيار اللون بجوار التسمية Color. ستظهر نافذة حوار قياسية لاختيار اللون.

  5. اختر لونًا رماديًا وانقر على OK.

  6. انقر على OK مرة أخرى في النافذة Layer Properties، وسترى تغيير اللون مطبَّقًا على الطبقة.

2.4.2. ★☆☆ جرّب بنفسك:

غيّر لون الطبقة water إلى الأزرق الفاتح. حاول استخدام اللوحة Layer Styling بدلًا من القائمة Layer Properties.

2.4.3. ★☆☆ تابع معنا: تغيير بنية الرمز

ما فعلناه حتى الآن جيد، لكن ترميز الطبقة يتجاوز مجرد لونها. نريد بعد ذلك إزالة الخطوط بين مناطق استخدامات الأراضي المختلفة لجعل الخريطة أقل ازدحامًا بصريًا.

  1. افتح النافذة Layer Properties الخاصة بالطبقة landuse.

    ضمن التبويب symbology Symbology، سترى نوع نافذة الحوار نفسه كما في السابق. لكنك هذه المرة ستفعل أكثر من مجرد تغيير اللون بسرعة.

  2. في شجرة طبقات الرمز، وسّع القائمة المنسدلة Fill واختر الخيار Simple fill.

  3. انقر على القائمة المنسدلة Stroke style. يُفترض أنها تعرض حاليًا خطًا قصيرًا والعبارة Solid Line.

  4. غيّر ذلك إلى No Line.

    ../../../_images/simple_fill_selected.png
  5. انقر على OK.

الآن لن تكون في الطبقة landuse أي خطوط بين المناطق.

2.4.4. ★☆☆ جرّب بنفسك:

  • غيّر ترميز الطبقة water مرة أخرى بحيث يكون لها حد خارجي أزرق أغمق.

  • غيّر ترميز الطبقة rivers إلى تمثيل معقول للمجاري المائية.

تذكّر: يمكنك استخدام الزر symbology Open the Layer Styling panel ورؤية جميع التغييرات فورًا. وتتيح لك تلك اللوحة أيضًا التراجع عن تغييرات فردية أثناء ترميز طبقة.

2.4.5. ★★☆ تابع معنا: الظهور المعتمد على مقياس الرسم

ستجد أحيانًا أن طبقة ما غير مناسبة لمقياس رسم معين. على سبيل المثال، قد تكون مجموعة بيانات لجميع القارات قليلة التفاصيل، وغير دقيقة جدًا على مستوى الشوارع. وعندما يحدث ذلك، ستريد أن تتمكن من إخفاء مجموعة البيانات عند مقاييس الرسم غير المناسبة.

في حالتنا، قد نقرر إخفاء المباني من العرض عند مقاييس الرسم الصغيرة. هذه الخريطة، على سبيل المثال...

../../../_images/buildings_small_scale.png

... ليست مفيدة جدًا. إذ يصعب تمييز المباني عند مقياس الرسم هذا.

لتفعيل العرض المعتمد على مقياس الرسم:

  1. افتح نافذة الحوار Layer Properties الخاصة بالطبقة buildings.

  2. فعّل التبويب rendering Rendering.

  3. فعّل العرض المعتمد على مقياس الرسم بالنقر على مربع الاختيار المسمى Scale dependent visibility:

  4. غيّر القيمة Minimum إلى 1:10000.

    ../../../_images/scale_dependent_visibility.png
  5. انقر على OK.

اختبر تأثير ذلك بالتكبير والتصغير في خريطتك، مع ملاحظة متى تختفي الطبقة buildings ومتى تعاود الظهور.

ملاحظة

يمكنك استخدام عجلة الفأرة للتكبير تدريجيًا. أو بدلًا من ذلك، استخدم أدوات التكبير للتكبير إلى نافذة محددة:

zoomIn zoomOut

2.4.6. ★★☆ تابع معنا: إضافة طبقات الرمز

الآن بعد أن عرفت كيف تغيّر الترميز البسيط للطبقات، فالخطوة التالية هي إنشاء ترميز أكثر تعقيدًا. يتيح لك QGIS ذلك باستخدام طبقات الرمز (symbol layers).

  1. عُد إلى لوحة خصائص الرمز للطبقة landuse (بالنقر على Simple fill في شجرة طبقات الرمز).

    في هذا المثال، ليس للرمز الحالي حدّ خارجي (أي أنه يستخدم نمط الحدود No Line).

    ../../../_images/simple_fill_selected.png
  2. حدّد المستوى Fill في الشجرة وانقر على الزر symbologyAdd Add symbol layer. ستتغير نافذة الحوار لتبدو تقريبًا هكذا، مع إضافة طبقة رمز جديدة:

    ../../../_images/new_symbol_layer.png

    قد تظهر مختلفة بعض الشيء في اللون مثلًا، لكنك ستغيّر ذلك على أي حال.

أصبحت هناك الآن طبقة رمز ثانية. ولأنها ذات لون مصمت، فإنها بالطبع ستخفي نوع الرمز السابق تمامًا. كما أن لها نمط الحدود Solid Line الذي لا نريده. من الواضح أنه يجب تغيير هذا الرمز.

ملاحظة

من المهم ألا تخلط بين طبقة الخريطة وطبقة الرمز. طبقة الخريطة هي بيانات متجهية (أو شبكية) جرى تحميلها في الخريطة. أما طبقة الرمز فهي جزء من الرمز المستخدم لتمثيل طبقة الخريطة. سيشير هذا المقرر عادةً إلى طبقة الخريطة بكلمة طبقة فقط، أما طبقة الرمز فستُسمّى دائمًا طبقة رمز، منعًا للالتباس.

مع تحديد طبقة الرمز Simple Fill الجديدة:

  1. اضبط نمط الحدود على No Line، كما فعلت سابقًا.

  2. غيّر نمط التعبئة إلى نمط غير Solid أو No brush. على سبيل المثال:

    ../../../_images/new_fill_settings.png
  3. انقر على OK.

يمكنك الآن رؤية النتائج وتعديلها حسب الحاجة. بل يمكنك إضافة عدة طبقات رمز إضافية وإنشاء نوع من النسيج (texture) لطبقتك بهذه الطريقة.

../../../_images/multiple_symbol_layers.png

إنه أمر ممتع! لكن من المحتمل أن فيه ألوانًا أكثر مما يناسب خريطة حقيقية...

2.4.7. ★★☆ جرّب بنفسك:

مع تذكّر التكبير عند الحاجة، أنشئ نسيجًا بسيطًا وغير مشتّت للانتباه للطبقة buildings باستخدام الطرق السابقة.

2.4.8. ★★☆ تابع معنا: ترتيب مستويات الرمز

عند رسم طبقات الرمز، فإنها تُرسم أيضًا بتسلسل معيّن، على نحو مشابه لطريقة رسم طبقات الخريطة المختلفة. وهذا يعني أن وجود طبقات رمز كثيرة في رمز واحد قد يؤدي في بعض الحالات إلى نتائج غير متوقعة.

  1. أضف إلى الطبقة roads طبقة رمز إضافية (باستخدام طريقة إضافة طبقات الرمز الموضحة أعلاه).

  2. اجعل قيمة Stroke width للخط الأساسي 1.5 ولونه أسود.

  3. اجعل سُمك الطبقة الجديدة العليا 0.8 ولونها أبيض.

ستلاحظ حدوث ما يلي:

../../../_images/bad_roads_symbology.png

حسنًا، أصبح للطرق الآن ترميز يشبه الشارع، لكنك ترى أن الخطوط تتداخل فوق بعضها عند كل تقاطع. وهذا ليس ما نريده إطلاقًا!

لمنع حدوث ذلك، يمكنك ترتيب مستويات الرمز ومن ثم التحكم في الترتيب الذي تُرسم به طبقات الرمز المختلفة.

لتغيير ترتيب طبقات الرمز:

  1. حدّد الطبقة Line العليا في شجرة طبقات الرمز.

  2. انقر على Advanced ► Symbol levels... في الزاوية السفلية اليمنى من النافذة.

    ../../../_images/symbol_levels_main_dialog.png

    سيفتح ذلك نافذة حوار كهذه:

    ../../../_images/symbol_levels_dialog.png
  3. فعّل الخيار checkbox Enable symbol levels. يمكنك بعدها ضبط ترتيب طبقة كل رمز بإدخال رقم المستوى المقابل. المستوى 0 هو الطبقة السفلى.

    في حالتنا، نريد فقط تفعيل الخيار، هكذا:

    ../../../_images/correct_symbol_layers.png

    سيؤدي هذا إلى رسم الخط الأبيض فوق حدود الخط الأسود السميك:

  4. انقر على OK مرتين للعودة إلى الخريطة.

    ستبدو الخريطة الآن هكذا:

    ../../../_images/better_roads_symbology.png

عند الانتهاء، تذكّر حفظ الرمز نفسه حتى لا تفقد عملك إذا غيّرت الرمز مرة أخرى في المستقبل. يمكنك حفظ نمط الرمز الحالي بالنقر على الزر Save Style... أسفل نافذة الحوار Layer Properties. سنستخدم الصيغة QGIS QML Style File.

احفظ النمط في المجلد solution/styles/better_roads.qml. يمكنك تحميل نمط محفوظ سابقًا في أي وقت بالنقر على الزر Load Style.... قبل تغيير أي نمط، ضع في اعتبارك أن أي نمط غير محفوظ تستبدله سيضيع.

2.4.9. ★★☆ جرّب بنفسك:

غيّر مظهر الطبقة roads مرة أخرى.

اجعل الطرق ضيقة وصفراء، مع حدّ خارجي رفيع رمادي فاتح وخط أسود رفيع في المنتصف. تذكّر أنك قد تحتاج إلى تغيير ترتيب رسم الطبقات عبر نافذة الحوار Advanced ► Symbol levels....

../../../_images/target_road_symbology.png

2.4.10. ★★★ جرّب بنفسك:

تعمل مستويات الرمز أيضًا مع الطبقات المصنّفة (أي الطبقات ذات الرموز المتعددة). وبما أننا لم نتناول التصنيف بعد، فستعمل على بيانات بسيطة مصنّفة مسبقًا.

  1. أنشئ مشروعًا جديدًا وأضف مجموعة البيانات roads فقط.

  2. طبّق على الطبقة ملف النمط advanced_levels_demo.qml الموجود في exercise_data/styles. يمكن فعل ذلك عبر القائمة المنسدلة Style ► Load Style... أسفل نافذة الحوار Layer Properties.

  3. كبّر إلى منطقة Swellendam.

  4. باستخدام طبقات الرمز، تأكد من أن الحدود الخارجية للطبقات تنساب في بعضها كما في الصورة أدناه:

    ../../../_images/correct_advanced_levels.png

2.4.11. ★★☆ تابع معنا: أنواع طبقات الرمز

إضافة إلى ضبط ألوان التعبئة واستخدام الأنماط المعرّفة مسبقًا، يمكنك استخدام أنواع مختلفة تمامًا من طبقات الرمز. النوع الوحيد الذي استخدمناه حتى الآن هو النوع Simple Fill. وتتيح لك أنواع طبقات الرمز الأكثر تقدمًا تخصيص رموزك بدرجة أكبر.

لكل نوع من البيانات المتجهية (نقطة وخط ومضلع) مجموعته الخاصة من أنواع طبقات الرمز. سنلقي نظرة أولًا على الأنواع المتاحة للنقاط.

أنواع طبقات رموز النقاط

  1. ألغِ تحديد جميع الطبقات ما عدا places.

  2. غيّر خصائص الرمز للطبقة places:

    ../../../_images/places_layer_properties.png
  3. يمكنك الوصول إلى أنواع طبقات الرمز المختلفة بتحديد الطبقة Simple marker في شجرة طبقات الرمز، ثم النقر على القائمة المنسدلة Symbol layer type:

    ../../../_images/marker_type_dropdown.png
  4. استكشف الخيارات المختلفة المتاحة لك، واختر رمزًا بتنسيق تراه مناسبًا.

  5. إن كنت مترددًا، فاستخدم Simple marker دائريًا بحدود بيضاء وتعبئة خضراء فاتحة، مع Size بقيمة 3.00 و Stroke width بقيمة 0.5.

أنواع طبقات رموز الخطوط

لرؤية الخيارات المختلفة المتاحة لبيانات الخطوط:

  1. غيّر Symbol layer type لطبقة الرمز العليا في الطبقة roads إلى Marker line:

    ../../../_images/change_to_marker_line.png
  2. حدّد الطبقة Simple marker في شجرة طبقات الرمز. غيّر خصائص الرمز لتطابق نافذة الحوار هذه:

    ../../../_images/simple_marker_line_properties.png
  3. حدّد الطبقة Marker line وغيّر الفاصل إلى 1.00:

    ../../../_images/marker_line_interval.png
  4. تأكد من صحة مستويات الرمز (عبر نافذة الحوار Advanced ► Symbol levels التي استخدمناها سابقًا) قبل تطبيق النمط.

بعد تطبيق النمط، ألقِ نظرة على نتائجه على الخريطة. كما ترى، تغيّر هذه الرموز اتجاهها مع الطريق لكنها لا تنحني معه دائمًا. هذا مفيد لبعض الأغراض دون غيرها. إن شئت، يمكنك إعادة طبقة الرمز المعنية إلى ما كانت عليه سابقًا.

أنواع طبقات رموز المضلعات

لرؤية الخيارات المختلفة المتاحة لبيانات المضلعات:

  1. غيّر Symbol layer type للطبقة water، كما فعلت سابقًا مع الطبقات الأخرى.

  2. استكشف ما يمكن أن تفعله الخيارات المختلفة في القائمة.

  3. اختر واحدًا منها تراه مناسبًا.

  4. إن كنت مترددًا، فاستخدم Point pattern fill مع الخيارات التالية:

    ../../../_images/pattern_fill_size.png
    ../../../_images/pattern_fill_distances.png
  5. أضف طبقة رمز جديدة من النوع العادي Simple fill.

  6. اجعلها بنفس اللون الأزرق الفاتح مع حدود زرقاء أغمق.

  7. انقلها أسفل طبقة رمز نمط النقاط باستخدام الزر Move down:

    ../../../_images/simple_fill_move_down.png

والنتيجة أن لديك رمزًا ذا نسيج لطبقة المياه، مع ميزة إضافية هي أنه يمكنك تغيير حجم النقاط المفردة التي تكوّن النسيج وشكلها والمسافة بينها.

2.4.13. ★★★ تابع معنا: ترميز مولّد الأشكال الهندسية (Geometry generator)

يمكنك استخدام ترميز مولّد الأشكال الهندسية (Geometry generator) مع جميع أنواع الطبقات (نقاط وخطوط ومضلعات). ويعتمد الرمز الناتج مباشرةً على نوع الطبقة.

باختصار شديد، يتيح لك ترميز مولّد الأشكال الهندسية تشغيل بعض العمليات المكانية داخل الترميز نفسه. على سبيل المثال، يمكنك تشغيل عملية مكانية حقيقية لحساب النقاط المركزية (centroid) على طبقة مضلعات دون إنشاء طبقة نقاط.

علاوة على ذلك، لديك جميع خيارات التنسيق لتغيير مظهر الرمز الناتج.

لنجرّب ذلك!

  1. حدّد الطبقة water.

  2. انقر على Simple fill وغيّر Symbol layer type إلى Geometry generator.

    ../../../_images/geometry_generator.png
  3. قبل البدء بكتابة الاستعلام المكاني، علينا اختيار نوع الشكل الهندسي الناتج (Geometry Type). في هذا المثال سننشئ نقاطًا مركزية لكل معلم، لذا غيّر نوع الشكل الهندسي إلى Point / Multipoint.

  4. لنكتب الآن الاستعلام في لوحة الاستعلام:

    centroid($geometry)
    
    ../../../_images/geometry_generator_query.png
  5. عند النقر على OK سترى أن الطبقة water تُرسم كطبقة نقاط! لقد شغّلنا للتوّ عملية مكانية داخل ترميز الطبقة نفسه، أليس هذا مذهلًا؟

    ../../../_images/geometry_generator_result.png

باستخدام ترميز مولّد الأشكال الهندسية يمكنك فعلًا تجاوز حدود الترميز العادي.

★★★ جرّب بنفسك:

مولّد الأشكال الهندسية ما هو إلا مستوى رمز آخر. حاول إضافة Simple fill آخر أسفل مستوى Geometry generator.

غيّر أيضًا مظهر العلامة البسيطة (Simple marker) في ترميز مولّد الأشكال الهندسية.

يجب أن تبدو النتيجة النهائية هكذا:

../../../_images/geometry_generator_preview.png

2.4.14. ★★★ تابع معنا: إنشاء تعبئة SVG مخصصة

ملاحظة

لإجراء هذا التمرين، يجب أن يكون برنامج تحرير الرسوم المتجهية المجاني Inkscape مثبّتًا لديك.

  1. شغّل برنامج Inkscape. ستظهر لك الواجهة التالية:

    ../../../_images/inkscape_default.png

    ستجدها مألوفة إن كنت قد استخدمت برامج أخرى لتحرير الصور المتجهية، مثل Corel.

    أولًا، سنغيّر لوحة الرسم إلى حجم مناسب لنسيج صغير.

  2. انقر على عنصر القائمة File ► Document Properties. سيعرض لك ذلك نافذة الحوار Document Properties.

  3. غيّر Units إلى px.

  4. غيّر Width و Height إلى 100.

  5. أغلق نافذة الحوار عند الانتهاء.

  6. انقر على عنصر القائمة View ► Zoom ► Page لرؤية الصفحة التي تعمل عليها.

  7. حدّد الأداة Circle:

    ../../../_images/inkscape_circle_tool.png
  8. انقر واسحب على الصفحة لرسم قطع ناقص. ولتحويل القطع الناقص إلى دائرة، اضغط باستمرار على الزر Ctrl أثناء الرسم.

  9. انقر بزر الفأرة الأيمن على الدائرة التي أنشأتها للتوّ وافتح خيارات Fill and Stroke الخاصة بها. يمكنك تعديل طريقة رسمها، مثل:

    1. غيّر لون Fill إلى لون رمادي مزرق فاتح نوعًا ما،

    2. أسند إلى الحدود لونًا أغمق في التبويب Stroke paint،

    3. وقلّل سُمك الحدود من التبويب Stroke style.

    ../../../_images/inkscape_stroke_fill.png
  10. ارسم خطًا باستخدام الأداة Pencil:

    1. انقر مرة واحدة لبدء الخط. اضغط باستمرار على Ctrl لجعله يلتقط بزيادات قدرها 15 درجة.

    2. حرّك المؤشر أفقيًا وضع نقطة بنقرة بسيطة.

    3. انقر والتقط رأس الخط وارسم خطًا رأسيًا ينتهي بنقرة بسيطة.

    4. صِل الآن بين الرأسين الطرفيين.

    5. غيّر لون رمز المثلث وعرضه ليطابقا حدود الدائرة، وحرّكه حسب الحاجة، بحيث تنتهي إلى رمز مثل هذا:

    ../../../_images/inkscape_final_symbol.png
  11. إذا كان الرمز الذي حصلت عليه يرضيك، فاحفظه باسم landuse_symbol كملف SVG ضمن المجلد الذي يوجد فيه المقرر، تحت exercise_data/symbols.

في QGIS:

  1. افتح Layer Properties للطبقة landuse.

  2. في التبويب symbology Symbology، غيّر بنية الرمز بتغيير Symbol Layer Type إلى SVG Fill كما هو موضح أدناه.

  3. انقر على الزر ... ثم Select File... لتحديد صورة SVG الخاصة بك.

    تُضاف إلى شجرة الرمز ويمكنك الآن تخصيص خصائصها المختلفة (الألوان، الزاوية، المؤثرات، الوحدات...).

    ../../../_images/svg_symbol_settings.png

بعد اعتماد نافذة الحوار، يجب أن تصبح معالم الطبقة landuse مغطاة بمجموعة من الرموز تُظهر نسيجًا كالذي في الخريطة التالية. إذا لم تكن الأنسجة مرئية، فقد تحتاج إلى التكبير في لوحة الخريطة أو ضبط قيمة أكبر لـ Texture width في خصائص الطبقة.

../../../_images/svg_symbol_result.png

2.4.15. ★★☆ تابع معنا: الإخفاء (Masking)

تتيح لك ميزة الإخفاء (Masking) إخفاء طبقة رمز ما باستخدام طبقة رمز أخرى أو تسمية.

في التمرين التالي، نريد ضبط الرسم بحيث تُخفي تسميات المضلعات الجزء الأسود من طبقة الخطوط.

  1. حمّل الملف selective_masking.qgs من مجموعة البيانات في المجلد exercise_data/masking.

  2. افتح نافذة Layer Properties للطبقة polys.

    في التبويب labelingSingle Labels، سترى أن Single Labels labelingSingle قد عُرّفت مسبقًا.

  3. من التبويب Labels، حدّد labelmask Mask (وليس Masks في قائمة الفئات العامة)

  4. فعّل إخفاء التسميات بتحديد الخيار unchecked Enable mask

    تخبرك رسالة بأنه يمكن لاحقًا اختيار شكل إخفاء التسمية المعرّف الآن كمصدر إخفاء لإخفاء طبقات رمز أخرى. لنفعل ذلك.

  5. انقر على OK

  6. افتح نافذة Layer Properties للطبقة lines.

  7. انتقل إلى التبويب labelmask Masks

  8. انقر على مربع اختيار الجزء الأسود من خط الطبقة lines ضمن طبقات الرمز المُخفاة

    تحذّرك رسالة من أنه يجب تحديد كل من طبقات الرمز المُخفية والمُخفاة لتتمكن من حفظ إعدادات الإخفاء. لنفعل ذلك مرة أخرى.

  9. انقر على مربع الاختيار Label mask الخاص بـ polys

    تختفي الرسالة، ويمكنك الآن حفظ إعداداتك بأمان.

    ../../../_images/mask_selection.png
  10. انقر على OK

يمكنك أن ترى الآن أن التسميات تُخفي الجزء الأسود من الخطوط، تاركة الجزء الأصفر فقط.

../../../_images/label_masking.png

2.4.16. ★★☆ تابع معنا: الإخفاء باستخدام رموز النقاط

نريد الآن إخفاء الجزء الأسود من الخطوط باستخدام الطائرات السوداء فقط التي تمثّل الطبقة points (أي فئتي النقاط B52 و Jet). ولزيادة الوضوح، يمكنك إيقاف إظهار الطبقة polys.

  1. افتح نافذة Layer Properties للطبقة points.

    في التبويب symbology Symbology، سترى أنه قد عُرّفت أداة رسم categorizedSymbol Categorized بثلاثة رموز مختلفة حسب قيمة الحقل Class.

  2. انقر نقرًا مزدوجًا على أيقونة الطائرة B52 في العمود Symbol

    ../../../_images/plane_symbology.png
  3. انقر على الزر symbologyAdd Add symbol layer واختر Mask من Symbol layer type

    يظهر تسلسل هرمي جديد Mask (طبقة رمز) > Marker (رمز) > Simple Marker (طبقة رمز) أسفل الرمز الجذري Marker.

    ../../../_images/mask_hierarchy.png

    لنعرّف الآن قناع إخفاء مطابقًا لعلامة الطائرة لكنه أكبر قليلًا.

  4. حدّد طبقة الرمز Simple Marker المنشأة حديثًا وغيّر Symbol layer type الخاص بها إلى SVG marker

  5. اجعل مسار ملف SVG مطابقًا لمسار علامة SVG الموجودة مسبقًا، والحجم أكبر (24 مليمترًا خيار جيد جدًا لهذه الحالة).

    لون القناع لا يهم هنا، إذ لا يُستخدم في الإخفاء سوى الشكل. كما أن ترتيب طبقات الرمز لا أهمية له في هذه الحالة.

    يجب أن تحصل على شيء كهذا:

    ../../../_images/point_masking.png
  6. كرّر العمليات نفسها على الرمز Jet.

  7. انقر على OK

  8. افتح نافذة Layer Properties للطبقة lines.

  9. انتقل إلى التبويب labelmask Masks.

    مربع اختيار الجزء الأسود من خط الطبقة lines ضمن طبقات الرمز المُخفاة محدَّد مسبقًا من إعداداتنا السابقة.

  10. ألغِ تحديد مربع الاختيار Label mask الخاص بـ polys وحدّد كلًا من B52 و Jet ضمن Mask symbol layer

  11. انقر على OK

ترى الآن أن الطائرات السوداء تُخفي الجزء الأسود من الخطوط، ولا يظهر سوى الجزء الأصفر.

../../../_images/points_masking.png

2.4.17. الخلاصة

لقد حوّل تغيير الترميز للطبقات المختلفة مجموعةً من الملفات المتجهية إلى خريطة مقروءة. فلم يعد بإمكانك رؤية ما يحدث فحسب، بل أصبح منظرها جميلًا أيضًا!

2.4.18. قراءات إضافية

أمثلة على خرائط جميلة

2.4.19. ما التالي؟

تغيير الرموز لطبقات كاملة أمر مفيد، لكن المعلومات الواردة في كل طبقة ليست متاحة بعد لقارئ هذه الخرائط. ما أسماء الشوارع؟ إلى أي مناطق إدارية تنتمي مناطق معيّنة؟ ما المساحات النسبية للمزارع؟ كل هذه المعلومات ما زالت مخفية. سيشرح الدرس التالي كيف تمثّل هذه البيانات على خريطتك.

ملاحظة

هل تذكرت حفظ خريطتك مؤخرًا؟