5.1. الدرس: إنشاء مجموعة بيانات متجهية جديدة

لا بد أن تأتي البيانات التي تستخدمها من مكان ما. في معظم التطبيقات الشائعة تكون البيانات موجودة مسبقًا؛ لكن كلما كان المشروع أكثر خصوصية وتخصصًا، قلّ احتمال أن تكون البيانات متاحة مسبقًا. وفي مثل هذه الحالات، ستحتاج إلى إنشاء بياناتك الجديدة بنفسك.

هدف هذا الدرس: إنشاء مجموعة بيانات متجهية جديدة.

5.1.1. ★☆☆ تابع معنا: نافذة حوار إنشاء الطبقة

قبل أن تتمكن من إضافة بيانات متجهية جديدة، تحتاج إلى مجموعة بيانات متجهية تضيفها إليها. في حالتنا، ستبدأ بإنشاء بيانات جديدة كليًا، بدلًا من تحرير مجموعة بيانات موجودة. لذلك ستحتاج إلى تعريف مجموعة بياناتك الجديدة أولًا.

  1. افتح QGIS وأنشئ مشروعًا فارغًا جديدًا.

  2. انتقل إلى عنصر القائمة Layer ► Create Layer ► New Shapefile Layer وانقر عليه. ستظهر لك نافذة الحوار New Shapefile Layer التي تتيح لك تعريف طبقة جديدة.

    ../../../_images/create_vector_layer.png
  3. انقر على ... بجوار الحقل File name. ستظهر نافذة حوار للحفظ.

  4. انتقل إلى المجلد exercise_data.

  5. احفظ طبقتك الجديدة باسم school_property.shp.

    من المهم أن تقرّر نوع مجموعة البيانات التي تريدها في هذه المرحلة. فكل نوع من أنواع الطبقات المتجهية "مبني بطريقة مختلفة" في الخلفية، لذا لا يمكنك تغيير نوع الطبقة بعد إنشائها.

    في التمرين التالي، سننشئ معالم جديدة تصف مساحات. ولمثل هذه المعالم، ستحتاج إلى إنشاء مجموعة بيانات مضلعات.

  6. في Geometry Type، اختر Polygon من القائمة المنسدلة:

    ../../../_images/polygon_selected.png

    لا يؤثر هذا في بقية نافذة الحوار، لكنه سيؤدي إلى استخدام النوع الصحيح من الأشكال الهندسية عند إنشاء مجموعة البيانات المتجهية.

    يتيح لك الحقل التالي تحديد نظام الإحداثيات المرجعي (CRS). ونظام الإحداثيات المرجعي هو طريقة لربط الإحداثيات العددية بموقع على سطح الأرض. راجع دليل المستخدم حول العمل مع الإسقاطات لمعرفة المزيد.

    سنستخدم في هذا المثال نظام الإحداثيات المرجعي الافتراضي المرتبط بهذا المشروع، وهو WGS84.

    ../../../_images/default_crs.png

    توجد بعد ذلك مجموعة من الحقول تحت New Field. افتراضيًا، تملك الطبقة الجديدة سمة واحدة فقط، هي الحقل id (الذي ينبغي أن تراه في Fields list) أدناه. لكن لكي تكون البيانات التي تنشئها مفيدة، عليك فعلًا أن تقول شيئًا عن المعالم التي ستنشئها في هذه الطبقة الجديدة. ولأغراضنا الحالية، يكفي إضافة حقل واحد اسمه name يحتوي على Text data ويقتصر طول النص فيه على 80 حرفًا.

  7. كرّر الإعداد أدناه، ثم انقر على الزر Add to Fields List:

    ../../../_images/new_attribute.png
  8. تحقّق من أن نافذة الحوار لديك تبدو الآن هكذا:

    ../../../_images/new_attribute_added.png
  9. انقر على OK

ينبغي أن تظهر الطبقة الجديدة في لوحة Layers.

5.1.2. ★☆☆ تابع معنا: مصادر البيانات

عندما تنشئ بيانات جديدة، فمن البديهي أن تكون عن كائنات موجودة فعلًا على أرض الواقع. لذلك ستحتاج إلى الحصول على معلوماتك من مكان ما.

توجد طرق كثيرة مختلفة للحصول على بيانات عن الكائنات. فمثلًا، يمكنك استخدام جهاز GPS لالتقاط نقاط في العالم الحقيقي، ثم استيراد البيانات إلى QGIS بعد ذلك. أو يمكنك مسح النقاط باستخدام جهاز ثيودوليت، وإدخال الإحداثيات يدويًا لإنشاء معالم جديدة. أو يمكنك استخدام عملية الرقمنة لتتبّع الكائنات من بيانات الاستشعار عن بُعد، مثل صور الأقمار الصناعية أو الصور الجوية.

سنستخدم في مثالنا أسلوب الرقمنة. تتوفر مجموعات بيانات شبكية للعيّنة، لذا ستحتاج إلى استيرادها حسب الحاجة.

  1. انقر على الزر dataSourceManager Data Source Manager.

  2. اختر raster Raster على الجانب الأيسر.

  3. في لوحة Source، انقر على الزر ...:

  4. انتقل إلى exercise_data/raster/.

  5. اختر الملف 3420C_2010_327_RGB_LATLNG.tif.

  6. انقر على Open لإغلاق نافذة الحوار.

    ../../../_images/add_raster1.png
  7. انقر على Add ثم Close. ستُحمَّل صورة في خريطتك.

    ../../../_images/raster_added.png
  8. إن لم تظهر لك صورة جوية، فحدّد الطبقة الجديدة وانقر بالزر الأيمن واختر Zoom to Layer من قائمة السياق.

    ../../../_images/zoom_to_raster.png
  9. انقر على الزر zoomIn Zoom In، وكبّر إلى المنطقة المظلّلة باللون الأزرق أدناه:

    ../../../_images/map_area_zoom.png

أنت الآن مستعد لرقمنة هذه الحقول الثلاثة:

../../../_images/field_outlines1.png

قبل بدء الرقمنة، لننقل الطبقة school_property فوق الصورة الجوية.

  1. حدّد الطبقة school_property في لوحة Layers واسحبها إلى الأعلى.

../../../_images/move_school_layer.png

لبدء الرقمنة، ستحتاج إلى الدخول في وضع التحرير. تتطلب برامج نظم المعلومات الجغرافية هذا عادةً لمنعك من تحرير بيانات مهمة أو حذفها عن طريق الخطأ. ويُفعَّل وضع التحرير أو يُعطَّل لكل طبقة على حدة.

للدخول في وضع التحرير للطبقة school_property:

  1. انقر على الطبقة school_property في لوحة Layers لتحديدها.

  2. انقر على الزر toggleEditing Toggle Editing.

    إن لم تعثر على هذا الزر، فتحقّق من أن شريط الأدوات Digitizing مفعّل. ينبغي أن توجد علامة اختيار بجوار عنصر القائمة View ► Toolbars ► Digitizing.

    بمجرد دخولك في وضع التحرير، سترى أن بعض أدوات الرقمنة أصبحت نشطة:

    • capturePolygon Capture Polygon

    • vertexToolActiveLayer Vertex Tool

    لا تزال الأزرار الأخرى ذات الصلة غير نشطة، لكنها ستصبح نشطة عندما نبدأ بالتفاعل مع بياناتنا الجديدة.

    لاحظ أن الطبقة school_property في لوحة Layers أصبحت تحمل الآن أيقونة القلم، مما يدل على أنها في وضع التحرير.

  3. انقر على الزر capturePolygon Capture Polygon لبدء رقمنة حقول المدرسة.

    ستلاحظ أن مؤشر الفأرة أصبح على شكل علامة تصويب متقاطعة. يتيح لك هذا وضع النقاط التي سترقمنها بدقة أكبر. تذكّر أنه حتى أثناء استخدام أداة الرقمنة، يمكنك التكبير والتصغير على خريطتك بتدوير عجلة الفأرة، ويمكنك التحريك بالضغط المستمر على عجلة الفأرة والسحب داخل الخريطة.

    أول معلم سترقمنه هو athletics field:

    ../../../_images/school_area_one.png
  4. ابدأ الرقمنة بالنقر على نقطة ما على طول حافة الحقل.

  5. ضع مزيدًا من النقاط بالنقر على امتداد الحافة، حتى يغطي الشكل الذي ترسمه الحقل بالكامل.

    ../../../_images/school_field_outline.png
  6. بعد وضع آخر نقطة، انقر بالزر الأيمن لإنهاء رسم المضلع. سيؤدي هذا إلى إتمام المعلم وعرض نافذة الحوار Attributes.

  7. املأ القيم كما يلي:

    ../../../_images/school_area_one_attributes.png
  8. انقر على OK، وبذلك تكون قد أنشأت معلمًا جديدًا!

    ../../../_images/new_feature.png
  9. في لوحة Layers، حدّد الطبقة school_property.

  10. انقر بالزر الأيمن واختر Open Attribute Table من قائمة السياق.

    ../../../_images/open_attribute_table.png

    سترى في الجدول المعلم الذي أضفته للتو. وأثناء وجودك في وضع التحرير، يمكنك تحديث البيانات الوصفية بالنقر المزدوج على الخلية التي تريد تحديثها.

    ../../../_images/feature_table.png
  11. أغلق جدول البيانات الوصفية.

  12. لحفظ المعلم الجديد الذي أنشأناه للتو، انقر على الزر saveEdits Save Edits.

تذكّر أنك إن ارتكبت خطأً أثناء رقمنة معلم ما، يمكنك دائمًا تحريره بعد الانتهاء من إنشائه. فإن أخطأت، تابع الرقمنة حتى تنتهي من إنشاء المعلم كما سبق. ثم:

  1. انقر على الزر vertexToolActiveLayer Vertex Tool.

  2. مرّر الفأرة فوق الرأس الذي تريد نقله وانقر عليه بالزر الأيسر.

  3. حرّك الفأرة إلى الموقع الصحيح للرأس، وانقر بالزر الأيسر. سيؤدي هذا إلى نقل الرأس إلى الموقع الجديد.

    ../../../_images/select_vertex.png
    ../../../_images/moved_vertex.png

    يمكن استخدام الإجراء نفسه لنقل قطعة خطية، لكن عليك تمرير الفأرة فوق نقطة منتصف القطعة.

    إن أردت التراجع عن تغيير ما، يمكنك الضغط على الزر undo Undo أو Ctrl+Z.

  4. تذكّر أن تحفظ تغييراتك بالنقر على الزر saveEdits Save Edits.

  5. عند الانتهاء من التحرير، انقر على الزر toggleEditing Toggle Editing للخروج من وضع التحرير.

5.1.3. ★☆☆ جرّب بنفسك: رقمنة المضلعات

رقمن المدرسة نفسها والحقل العلوي. استعن بهذه الصورة:

../../../_images/field_outlines1.png

تذكّر أن كل معلم جديد يجب أن تكون له قيمة id فريدة!

ملاحظة

عند الانتهاء من إضافة المعالم إلى طبقة ما، تذكّر أن تحفظ تعديلاتك ثم تخرج من وضع التحرير.

ملاحظة

يمكنك تنسيق التعبئة والحدود وموضع التسميات وتنسيقها للطبقة school_property باستخدام الأساليب التي تعلّمتها في الدروس السابقة.

5.1.4. ★★☆ تابع معنا: استخدام جدول محرّر الرؤوس

من الطرق الأخرى لتحرير معلم ما إدخال قيم الإحداثيات الفعلية لكل رأس يدويًا باستخدام جدول Vertex Editor.

  1. تأكد من أنك في وضع التحرير على الطبقة school_property.

  2. إن لم يكن مفعّلًا بالفعل، فانقر على الزر vertexToolActiveLayer Vertex Tool.

  3. حرّك الفأرة فوق أحد معالم المضلعات التي أنشأتها في الطبقة school_property وانقر عليه بالزر الأيمن. سيؤدي هذا إلى تحديد المعلم وظهور لوحة Vertex Editor.

    ../../../_images/vertex_editor_table.png

    ملاحظة

    يحتوي هذا الجدول على إحداثيات رؤوس المعلم. لاحظ وجود سبعة رؤوس لهذا المعلم، مع أن ستة منها فقط تظهر بصريًا في منطقة الخريطة. وعند التدقيق، ستلاحظ أن للصفين 0 و6 إحداثيات متطابقة. هذان هما رأسا البداية والنهاية للشكل الهندسي للمعلم، وهما مطلوبان لإنشاء معلم مضلع مغلق.

  4. انقر واسحب مربعًا فوق رأس واحد أو عدة رؤوس من المعلم المحدد.

    ../../../_images/vertex_select.png

    سيتغيّر لون الرؤوس المحددة إلى الأزرق، وستظهر في جدول Vertex Editor الصفوف المقابلة مظلّلة، وهي تحتوي على إحداثيات الرؤوس.

    ../../../_images/vertex_selected.png
  5. لتحديث إحداثي ما، انقر نقرًا مزدوجًا بالزر الأيسر على الخلية التي تريد تحريرها في الجدول وأدخل القيمة المحدّثة. في هذا المثال، حُدّث الإحداثي x للصف 4 من 20.4450 إلى 20.4444.

    ../../../_images/edit_vertex_in_vertex_editor.png
  6. بعد إدخال القيمة المحدّثة، اضغط مفتاح Enter لتطبيق التغيير. سترى الرأس ينتقل إلى الموقع الجديد في نافذة الخريطة.

  7. عند الانتهاء من التحرير، انقر على الزر toggleEditing Toggle Editing للخروج من وضع التحرير، واحفظ تعديلاتك.

5.1.5. ★☆☆ جرّب بنفسك: رقمنة الخطوط

سنرقمن مسارين غير مُعلَّمين بعدُ في طبقة الطرق؛ أحدهما ممر مشاة، والآخر درب ترابي. يمتد ممرّنا على طول الحافة الجنوبية لضاحية Railton، ويبدأ وينتهي عند طرق مُعلَّمة:

../../../_images/path_start_end.png

أما الدرب فيقع إلى الجنوب قليلًا:

../../../_images/track_start_end.png
  1. إن لم تكن طبقة roads في خريطتك بعد، فأضف الطبقة roads من ملف GeoPackage training-data.gpkg الموجود في المجلد exercise_data ضمن بيانات التدريب التي نزّلتها. يمكنك قراءة ★☆☆ تابع معنا: تحميل بيانات متجهية من قاعدة بيانات GeoPackage لمعرفة الطريقة.

  2. أنشئ مجموعة بيانات خطية جديدة بصيغة ESRI Shapefile باسم routes.shp في المجلد exercise_data، تحتوي على السمتين id و type (استعن بالأسلوب المتّبع أعلاه).

  3. فعّل وضع التحرير على الطبقة routes.

  4. بما أنك تعمل مع معلم خطي، انقر على الزر captureLine Add Line لبدء وضع رقمنة الخطوط.

  5. رقمن الممر والدرب على الطبقة routes، كلًّا على حدة. حاول اتّباع المسارين بأكبر دقة ممكنة، مع إضافة نقاط إضافية عند الزوايا والمنعطفات.

  6. اضبط قيمة السمة type على path أو track.

  7. استخدم نافذة الحوار Layer Properties لإضافة تنسيق إلى مساراتك. لا تتردد في استخدام أنماط مختلفة للممرات والدروب.

  8. احفظ تعديلاتك وأوقف وضع التحرير بالضغط على الزر toggleEditing Toggle Editing.

5.1.6. الخلاصة

أصبحت تعرف الآن كيفية إنشاء المعالم! لا تتناول هذه الدورة إضافة المعالم النقطية، لأن ذلك ليس ضروريًا حقًا بعد أن تكون قد عملت مع معالم أكثر تعقيدًا (الخطوط والمضلعات). فهي تعمل بالطريقة نفسها تمامًا، باستثناء أنك تنقر مرة واحدة فقط حيث تريد وضع النقطة، وتعطيها سمات كالمعتاد، ثم يُنشأ المعلم.

معرفة كيفية الرقمنة أمر مهم لأنها نشاط شائع جدًا في برامج نظم المعلومات الجغرافية.

5.1.7. ما التالي؟

المعالم في طبقة نظم المعلومات الجغرافية ليست مجرد صور، بل كائنات في الفضاء. فمثلًا، تعرف المضلعات المتجاورة أين تقع بالنسبة إلى بعضها. ويُسمّى هذا الطوبولوجيا. سترى في الدرس التالي مثالًا يوضّح سبب فائدة ذلك.