18.2.7. عناصر الجداول

يمكنك استخدام عناصر الجداول لتزيين خريطتك وشرحها:

  • جدول البيانات الوصفية: يستخرج تلقائيًا مجموعة فرعية من البيانات الوصفية لطبقة ما، بناءً على قواعد محددة مسبقًا

  • الجدول الثابت: يتيح إنشاء جداول بمحتويات مُدخلة يدويًا (أي بأسلوب جداول البيانات)، بحيث يمكنك إنشاء جداول مخصصة بالكامل.

18.2.7.1. عنصر جدول البيانات الوصفية

يمكن عرض البيانات الوصفية لأي طبقة في المشروع ضمن تخطيط الطباعة. استخدم الأداة addTable Add Attribute Table باتباع تعليمات إنشاء العناصر لإضافة عنصر جدول جديد يمكنك لاحقًا التعامل معه بالطريقة نفسها الموضحة في التعامل مع عناصر التخطيط.

افتراضيًا، يحمّل عنصر جدول البيانات الوصفية الجديد الصفوف الأولى من الطبقة الأولى (بالترتيب الأبجدي) مع جميع الحقول. لكن يمكنك تخصيص الجدول عبر لوحة Item Properties الخاصة به. وإلى جانب الخصائص المشتركة للعناصر، تتمتع هذه الميزة بالوظائف التالية (انظر شكل 18.40):

../../../../_images/attribute_properties.png

شكل 18.40 لوحة خصائص عنصر جدول البيانات الوصفية

الخصائص الرئيسية

توفّر مجموعة Main properties في جدول البيانات الوصفية الوظائف التالية (انظر شكل 18.41):

../../../../_images/attribute_mainproperties.png

شكل 18.41 مجموعة الخصائص الرئيسية لجدول البيانات الوصفية

  • بالنسبة إلى Source لا يمكنك افتراضيًا سوى اختيار Layer features التي تتيح لك اختيار Layer من الطبقات المتجهية المحمّلة في المشروع.

    يتيح لك الزر dataDefine Data-defined override بجانب قائمة الطبقات تغيير الطبقة المستخدمة لتعبئة الجدول ديناميكيًا، فمثلًا يمكنك ملء جدول البيانات الوصفية ببيانات وصفية لطبقات مختلفة في كل صفحة من صفحات الأطلس. لاحظ أن بنية الجدول المستخدمة (شكل 18.44) هي بنية الطبقة المعروضة في القائمة المنسدلة Layer وتبقى كما هي، أي أن ضبط جدول معرّف بالبيانات على طبقة ذات حقول مختلفة سيؤدي إلى أعمدة فارغة في الجدول.

    إذا فعّلت الخيار checkboxGenerate an atlas في لوحة Atlas (انظر توليد أطلس)، فهناك قيمتان إضافيتان ممكنتان لـ Source:

    • المعلم الحالي في الأطلس (انظر شكل 18.42): لن ترى أي خيار لاختيار الطبقة، وسيعرض عنصر الجدول صفًا واحدًا فقط يحتوي على البيانات الوصفية للمعلم الحالي من طبقة تغطية الأطلس.

    • و العناصر الفرعية للعلاقة (انظر شكل 18.43): سيظهر خيار بأسماء العلاقات. لا يمكن استخدام هذه الميزة إلا إذا عرّفت علاقة تكون فيها طبقة تغطية الأطلس هي الطبقة الأم، وسيعرض الجدول الصفوف الفرعية للمعلم الحالي في طبقة تغطية الأطلس.

  • يمكن استخدام الزر Refresh Table Data لتحديث الجدول عندما تتغير محتوياته الفعلية.

../../../../_images/attribute_mainatlas.png

شكل 18.42 الخصائص الرئيسية لجدول البيانات الوصفية في وضع 'Current atlas feature'

../../../../_images/attribute_mainrelation.png

شكل 18.43 الخصائص الرئيسية لجدول البيانات الوصفية في وضع 'Relation children'

  • يفتح الزر Attributes... نافذة الحوار Select Attributes (انظر شكل 18.44) التي يمكن استخدامها لتغيير المحتوى المعروض في الجدول. يعرض الجزء العلوي من النافذة قائمة البيانات الوصفية المراد عرضها، ويساعدك الجزء السفلي على فرز البيانات.

    ../../../../_images/attribute_select.png

    شكل 18.44 نافذة حوار اختيار البيانات الوصفية لجدول البيانات الوصفية

    في قسم Columns يمكنك:

    • نقل البيانات الوصفية لأعلى القائمة أو لأسفلها بتحديد الصفوف ثم استخدام الزرين arrowUp و arrowDown لإزاحة الصفوف. يمكن تحديد عدة صفوف ونقلها في وقت واحد.

    • إضافة سمة باستخدام الزر symbologyAdd. يضيف ذلك صفًا فارغًا في أسفل الجدول يمكنك فيه اختيار حقل ليكون قيمة السمة، أو إنشاء سمة عبر تعبير منتظم.

    • إزالة سمة باستخدام الزر symbologyRemove. يمكن تحديد عدة صفوف وإزالتها في وقت واحد.

    • إعادة جدول البيانات الوصفية إلى حالته الافتراضية باستخدام الزر Reset.

    • مسح الجدول باستخدام الزر Clear. يفيد ذلك عندما يكون لديك جدول كبير وتريد عرض عدد قليل من البيانات الوصفية فقط؛ فبدلًا من إزالة كل صف يدويًا، قد يكون من الأسرع مسح الجدول ثم إضافة الصفوف المطلوبة.

    • يمكن تغيير عناوين الخلايا بإضافة نص مخصص في العمود Heading.

    • يمكن التحكم في محاذاة الخلايا من خلال العمود Alignment الذي يحدد موضع النص داخل خلية الجدول.

    • يمكن التحكم في عرض الخلايا يدويًا بإضافة قيم مخصصة في العمود width.

    في قسم Sorting يمكنك:

    • إضافة سمة لفرز الجدول بها: اضغط على الزر symbologyAdd فيُضاف صف فارغ جديد. أدخل حقلًا أو تعبيرًا في العمود Attribute واضبط Sort order على تصاعدي أو تنازلي.

    • حدّد صفًا في القائمة واستخدم الزرين arrowUp و arrowDown لتغيير أولوية الفرز على مستوى السمة. يساعدك تحديد خلية في العمود Sort Order على تغيير ترتيب فرز حقل السمة.

    • استخدم الزر symbologyRemove لإزالة سمة من قائمة الفرز.

تصفية المعالم

توفر مجموعة Feature filtering في جدول البيانات الوصفية الوظائف التالية (انظر شكل 18.45):

../../../../_images/attribute_filter.png

شكل 18.45 مجموعة تصفية المعالم في جدول البيانات الوصفية

يمكنك:

  • تحديد Maximum rows (الحد الأقصى للصفوف) المراد عرضها.

  • تفعيل checkbox Remove duplicate rows from table لعرض السجلات الفريدة فقط.

  • تفعيل checkbox Show only visible features within a map واختيار Linked map المقابلة التي ستُعرض البيانات الوصفية لمعالمها المرئية.

  • الخيار checkbox Show only features intersecting Atlas feature متاح فقط عند تفعيل checkbox Generate an atlas. عند تفعيله يعرض جدولًا يحتوي فقط على المعالم التي تتقاطع مع معلم الأطلس الحالي.

  • تفعيل checkbox Filter with وتوفير عامل تصفية بالكتابة في سطر الإدخال أو إدراج تعبير منتظم باستخدام زر التعبير expression. فيما يلي بعض الأمثلة على عبارات التصفية التي يمكنك استخدامها عند تحميل طبقة المطارات من مجموعة البيانات النموذجية:

    • ELEV > 500

    • NAME = 'ANIAK'

    • NAME NOT LIKE 'AN%'

    • regexp_match( attribute( $currentfeature, 'USE' )  , '[i]')

    سيتضمن التعبير المنتظم الأخير المطارات التي يحتوي حقل السمة 'USE' فيها على الحرف 'i' فقط.

المظهر

توفر مجموعة Appearance في جدول البيانات الوصفية الوظائف التالية (انظر شكل 18.46):

../../../../_images/attribute_appearance.png

شكل 18.46 مجموعة المظهر في جدول البيانات الوصفية

  • انقر على checkbox Show empty rows لملء جدول البيانات الوصفية بخلايا فارغة. يمكن استخدام هذا الخيار أيضًا لتوفير خلايا فارغة إضافية عندما تكون لديك نتيجة لعرضها!

  • باستخدام Cell margins يمكنك تحديد الهامش حول النص في كل خلية من خلايا الجدول.

  • باستخدام Display header يمكنك أن تختار من قائمة أحد الخيارات: 'On first frame'، أو 'On all frames' وهو الخيار الافتراضي، أو 'No header'.

  • يتحكم الخيار Empty table فيما سيُعرض عندما تكون نتيجة التحديد فارغة.

    • رسم الترويسة فقط: يرسم الترويسة فقط إلا إذا اخترت 'No header' في Display header.

    • إخفاء الجدول بأكمله: يرسم خلفية الجدول فقط. يمكنك تفعيل checkbox Don't draw background if frame is empty في Frames لإخفاء الجدول تمامًا.

    • عرض رسالة محددة: يرسم الترويسة ويضيف خلية تمتد عبر جميع الأعمدة وتعرض رسالة مثل 'No result' يمكن توفيرها في الخيار Message to display

  • لا يُفعَّل الخيار Message to display إلا عند اختيار Show set message في Empty table. تُعرض الرسالة المحددة في الصف الأول من الجدول عندما تكون النتيجة جدولًا فارغًا.

  • باستخدام Background color يمكنك ضبط لون خلفية الجدول عبر عنصر الواجهة محدد الألوان. يساعدك الخيار Advanced customization على تحديد ألوان خلفية مختلفة لكل خلية (انظر شكل 18.47)

../../../../_images/attribute_background.png

شكل 18.47 نافذة حوار الخلفية المتقدمة لجدول البيانات الوصفية

  • checkbox Apply layer conditional styling colors: يُطبَّق التنسيق الشرطي للجدول الموجود في الطبقة داخل جدول البيانات الوصفية في التخطيط (لون الخلفية، وعائلة الخط، وخصائص مثل الغامق والمائل والمشطوب والتسطير واللون، ...). تكون لقواعد التنسيق الشرطي الأسبقية على إعدادات تنسيق جدول التخطيط الأخرى، فمثلًا ستتجاوز إعدادات لون خلفية الخلايا الأخرى مثل ألوان الصفوف المتناوبة.

  • باستخدام الخيار Wrap text on يمكنك تحديد حرف يُلَف عنده محتوى الخلية إلى سطر جديد في كل مرة يُصادَف فيها

  • باستخدام Oversized text تحدد السلوك عندما يكون العرض المحدد لعمود أصغر من طول محتواه. يمكن أن يكون التفاف النص أو اقتطاع النص.

ملاحظة

يوجد وصف لمزيد من خصائص عنصر جدول البيانات الوصفية في القسم الوظائف المشتركة للجداول.

18.2.7.2. عنصر الجدول الثابت

يمكن إدراج معلومات إضافية عن الخريطة يدويًا في جدول باختيار addManualTable Add Fixed Table واتباع تعليمات إنشاء العناصر لإضافة عنصر جدول جديد يمكنك التعامل معه لاحقًا بالطريقة نفسها الموضحة في التعامل مع عناصر التخطيط.

افتراضيًا، يظهر في تخطيط الخريطة جدول فارغ بعمودين وصفين مصغَّرين. عليك تخصيص الجدول في لوحة Item Properties. بالإضافة إلى الخصائص المشتركة للعناصر، تتمتع هذه الميزة بالوظائف التالية:

الخصائص الرئيسية

../../../../_images/fixedtable_table_designer.png

شكل 18.48 لوحة خصائص عنصر الجدول الثابت مع مصمّم الجداول

في Main properties، اضغط على Edit table... لفتح نافذة الحوار Table designer حيث يمكنك بناء جدولك (يؤدي النقر المزدوج على عنصر الجدول أيضًا إلى فتح نافذة المحرر):

  • على الجانب الأيسر من نافذة الحوار، يعرض إطار جدول عنصر الجدول النشط بمحتواه وإعداداته. انقر أو انقر نقرًا مزدوجًا على خلية واكتب نصًا لتعديل محتواها. اضغط Ctrl+Enter لإضافة فاصل أسطر (لنص متعدد الأسطر). منطق تحديد عدة خلايا في الجدول هو نفسه المتبع في جدول البيانات الوصفية للطبقة المتجهية. اسحب فاصل صف أو عمود وحرّكه لتغيير حجم الصف الذي فوقه أو العمود الذي قبله. يؤدي النقر المزدوج على الفاصل إلى تغيير حجم الصف الذي فوقه أو العمود الذي قبله ليلائم محتواه. يعرض النقر بالزر الأيمن على ترويسات الأعمدة أو الصفوف قائمة سياقية لإدراج أعمدة أو صفوف حول التحديد أو لحذفها.

  • من خلال القوائم الموجودة أعلى نافذة الحوار، يمكنك:

    • File ► Import Content From Clipboard: يستبدل محتويات الجدول.

    • File ► Close editor: يغلق نافذة الحوار Table Designer.

    • من القائمة Edit يمكنك العمل مع وظائف التحديد للصفوف والأعمدة:

      • Select all: تحديد جميع الخلايا في الجدول

      • Select columns أو Select Rows: عند تحديد خلايا في الجدول، يمكنك توسيع التحديد ليشمل أعمدتها أو صفوفها على التوالي

      • Clear Cells: يحذف محتوى الخلايا المحددة

    • القائمة Table هي المكان الذي تصمم فيه بنية الجدول. يمكنك:

      • Insert rows ► فوق التحديد أو تحته

      • Insert columns ► قبل التحديد أو بعده

      • Delete Rows أو Delete Columns للخلايا المحددة

      • Merge selected cells: حدّد عدة خلايا على شكل مستطيل ويمكنك دمجها وضم محتوياتها في الخلية العلوية اليسرى (التي يُطبَّق تنسيقها أيضًا على الخلية المدمجة، ما لم تكن هناك خلية من الصف أو العمود الأخير ضمن التحديد).

      • Split selected cells: حدّد خلية مدمجة ويمكنك تقسيمها مرة أخرى إلى خلاياها المنفردة. يُحتفظ بالنص الحالي في الخلية العلوية اليسرى، وتُملأ الخلايا الأخرى بمحتوياتها التي كانت عليها قبل الدمج، كما يُعاد تطبيق تنسيقها الأصلي.

      • checkbox Include Header Row الذي لا يمكن التحكم في تنسيقه إلا من عنصر الواجهة الخطوط وتنسيق النص

  • حدّد الخلايا، ويمكنك على يمين إطار الجدول توفير Cell Contents:

    • إما بإدخال محتوى كل خلية يدويًا، أو باستخدام expression Expression لتعبئتها تلقائيًا.

    • ضمن مجموعة Formatting، اضبط خيارات محددة تنطبق على التحديد وتكون لها الأسبقية على التنسيق العام لمحتوى الجدول:

      • باختيار Text format

      • بتفعيل checkbox Format as number (تتوفر عدة تنسيقات)

      • بتحديد Horizontal alignment و Vertical alignment

      • باختيار Background color

    • حدّد Cell Size من خلال Row height و Column width.

المظهر

توفر مجموعة Appearance في الجدول الثابت الوظائف التالية:

  • انقر على checkbox Show empty rows لملء جدول البيانات الوصفية بخلايا فارغة.

  • باستخدام Cell margins يمكنك تحديد الهامش حول النص في كل خلية من خلايا الجدول.

  • باستخدام Display header يمكنك أن تختار من قائمة أحد الخيارات: 'On first frame'، أو 'On all frames' وهو الخيار الافتراضي، أو 'No header'.

  • باستخدام Background color يمكنك ضبط لون خلفية الجدول عبر عنصر الواجهة محدد الألوان. يساعدك الخيار Advanced customization على تحديد ألوان خلفية مختلفة لكل خلية.

  • باستخدام Oversized text تحدد السلوك عندما يكون العرض المحدد لعمود أصغر من طول محتواه. يمكن أن يكون التفاف النص أو اقتطاع النص.

ملاحظة

يوجد وصف لمزيد من خصائص عنصر الجدول الثابت في القسم الوظائف المشتركة للجداول.

18.2.7.3. الوظائف المشتركة للجداول

إظهار الشبكة

توفر مجموعة Show grid في عناصر الجداول الوظائف التالية (انظر شكل 18.49):

../../../../_images/attribute_grid.png

شكل 18.49 مجموعة إظهار الشبكة في جدول البيانات الوصفية

  • فعّل checkbox Show grid عندما تريد عرض الشبكة، أي حدود خلايا الجدول. يمكنك أيضًا اختيار Draw horizontal lines أو Draw vertical lines أو كليهما.

  • باستخدام Line width يمكنك ضبط سماكة الخطوط المستخدمة في الشبكة.

  • يمكن ضبط Color الشبكة باستخدام عنصر واجهة اختيار الألوان.

الخطوط وتنسيق النص

توفر مجموعة Fonts and text styling في عناصر الجداول الوظائف التالية (انظر شكل 18.50):

../../../../_images/attribute_fonts.png

شكل 18.50 مجموعة الخطوط وتنسيق النص في جدول البيانات الوصفية

  • يمكنك تحديد خصائص Font لكل من Table heading و Table contents باستخدام عنصر الواجهة المتقدم إعدادات النص (مع النطاق العازل، والظل، وتأثيرات الرسم، والشفافية، والخلفية، والتلوين، ...). لاحظ أن هذه التغييرات لا تؤثر في الخلايا التي خُصِّص لها خط مخصص، سواء من القسم Appearance أو من نافذة الحوار Table Designer. لا يُستبدَل إلا تنسيق الخلايا ذات العرض الافتراضي.

  • بالنسبة إلى Table heading يمكنك أيضًا ضبط Alignment على Follow column alignment أو تجاوز هذا الإعداد باختيار Left أو Center أو Right. تُضبط محاذاة الأعمدة باستخدام نافذة الحوار Select Attributes (انظر شكل 18.44).

الإطارات

توفر مجموعة Frames في خصائص عنصر الجدول الوظائف التالية (انظر شكل 18.51):

../../../../_images/attribute_frame.png

شكل 18.51 مجموعة الإطارات في جدول البيانات الوصفية

  • باستخدام Resize mode يمكنك اختيار طريقة عرض محتويات جدول البيانات الوصفية:

    • Use existing frames يعرض النتيجة في الإطار الأول والإطارات المضافة فقط.

    • Extend to next page ينشئ العدد اللازم من الإطارات (والصفحات المقابلة لها) لعرض التحديد الكامل من جدول البيانات الوصفية. يمكن تحريك كل إطار في التخطيط. إذا غيّرت حجم إطار، فسيُقسَّم الجدول الناتج على الإطارات الأخرى. سيُقتطع الإطار الأخير ليلائم الجدول.

    • Repeat until finished ينشئ أيضًا العدد نفسه من الإطارات كما في الخيار Extend to next page، إلا أن جميع الإطارات ستكون بالحجم نفسه.

  • استخدم الزر Add Frame لإضافة إطار آخر بحجم الإطار المحدد نفسه. سيستمر الجزء من الجدول الذي لا يتسع له الإطار الأول في الإطار التالي عند استخدام وضع تغيير الحجم Use existing frames.

  • يمنع تفعيل checkbox Don't export page if frame is empty تصدير الصفحة عندما لا يحتوي إطار الجدول على أي محتوى. وهذا يعني أن جميع عناصر التخطيط الأخرى من خرائط ومقاييس رسم ومفاتيح خرائط وغيرها لن تظهر في النتيجة.

  • يمنع تفعيل checkbox Don't draw background if frame is empty رسم الخلفية عندما لا يحتوي إطار الجدول على أي محتوى.